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The days of simple paper handouts for students are over. Modern students
expect more from their professors, and thus assume that web-based course
materials will be made available.

This translates into additional work for the professor. It means creating a
homepage, adding course syllabi and other related documents, as well as a Vita,
research papers, and anything else the professor deems important.

Fortunately, one does not need to be a computer programmer or web developer.
While these tools are certainly nice to possess, they are not needed to be able to
have a basic web presence. The University has given each faculty member
sufficient server space and authoring tools that a personal web site can be
developed and maintained quite easily.

The purpose of this paper is to demonstrate how faculty can develop, modify,
and supplement their personal web pages on the WTAMU server. By the end of
this short paper, readers should be able to attend to the most basic functions of
their web page, and be able to include other documents that have been saved as
PDFs that can be loaded to the web server and viewed easily by students. Given
the length of this presentation, only basic web page authoring will be covered.

Getting Started

It is assumed that, for the purposes of this demonstration, you will be working
from the basic faculty web page that we have already created for you. If you were
to create your own page, the directions would not be much different.



The tool for editing/creating your web pages on campus is Netscape Composer.
This is “standard equipment” in the version 4.x Netscape browsers. All of your
files will reside in the “U” drive accessible through your faculty account. In your
“U” drive you have a folder called “homepage.” This is where all of your web
documents must reside.

The University computer staff has set up this folder to function as if it were your

personal web address. Anyone from the “outside” can view your personal page

by going to http://www.wtamu.edu/~ngerlich, for example (using first initial + last
name as the convention).
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However, for the purposes of editing your web page, you should use your
browser to open the file that resides in your homepage folder. The image above
shows what a prototype homepage looks like.

Upon launching Netscape, click File-> Open Page from the upper-left corner. A
dialog box will pop up; select Choose File. Then locate your U drive and
homepage folder. Once in the homepage folder, click on index.html. The index
page is your default homepage; whenever you are creating a web site for
yourself, the homepage must be called index.html.

Once you have done this, click Open, and your homepage will appear on your
screen.



To begin editing, you must now launch Composer. Click File->Edit Page. This
will open another window in which you can do your editing.

From this point forward, you may view your work by saving your changes in
Composer by clicking File-> Save, and then returning to your original Netscape
window. On the tool bar click Reload, and the newly-updated page will appear.

When you are finished, make sure your last changes have been saved in
Composer. You will likely go back and forth between Composer and Netscape
several times to view the intermediate changes in your page.

Font and Text Effects

Adding font and text effects is done quite easily from Composer. The basic
sequence is to highlight the text you wish to alter, which can be done by click-
dragging your mouse across that text. This will cause that text to become
highlighted in blue; while it is highlighted, you should then select your effect from
the toolbar above.

Text can be made into headers by selecting the first dropdown menu from the
left. Headers come in six sizes, with 1 being the largest, and 6 the smallest. By
default, headers are rendered in bold-face type. Headers generally are size 2
through size 4.

The next dropdown menu controls the font face. While you can select any of the
fonts that are loaded on your PC, it is wise to stick with only the most common
fonts. If the font you selected is not available on a user’s PC, the browser will
default to Times New Roman. For this reason, | usually restrict my fonts to either
a serif face (like Times New Roman), or a sans serif face like Arial. These fonts
are loaded on nearly every machine.

The third dropdown menu controls the font size. There are seven options,
ranging from 8pt to 36pt. It is considered “shouting” to use anything larger than
12pt for text. It should be noted that the font sizing menu can also be used to
create headers, but these will not automatically appear in bold face.

The fourth dropdown menu is for selecting the font color. A wide range of colors
is available, but text is traditionally displayed in black. If, however, a dark
background color is used, it may be advisable to use a different font color.

Next are three buttons for adding text effects. In order, these are bold, italic, and
underline. They may be used separately or in combination.

The next button is for bulk removal of font and text effects. Clicking this button
will remove any and all effects that have been applied to the highlighted text.



Lists

There are two basic types of lists available in HTML: ordered lists and unordered
lists. The former are lists that have a numerical or alphabetic “counter” before
each line item; the latter are “bulleted” lists. Both can be effective for presenting
lists of information so that they are easy to read.

Generally speaking, some type of text or header will precede a list. This should
be typed first. Hit “Enter” when done with this, and then select which type of list
you would like. The two selection buttons are on the tool bar following the
“Remove All Styles” button.

Either a bullet or number will appear below your text, after which you should type
your first entry. Hit Enter, and you’ll be ready to type the second one, and so on.
After your last line item, hit Enter. This will create yet another bullet or number.
Do not type anything, however, for you should then click once more the same
button you used to start the list. This will turn it off and allow you to resume
normal typing.

You can change some aspects of your list quite easily. By click-dragging (i.e.,
highlighting) the list, you can then right-click on the highlighted area. From the
subsequent pop-up menu, select Paragraph/List Properties. You can then select
which type of bulleted or ordered list you would like. It is possible to use discs,
circles, or squares for bullets, and a variety of alpha/numeric or Roman numerals
for ordered lists. For ordered lists, you can even specify at which element the
counting begins. Alignments can also be selected from this menu.

Alignment

Text can be aligned using the far right button on the toolbar. There are three
options: left, right, and center. The default is left, so this does not need to be
specified. Again, highlight the text you wish to align, and then select the
appropriate alignment.

Horizontal Rules

A horizontal rule (line) can be inserted at any point in the text. These are often
used to denote sections. These can be formed by clicking the H. Line button on

the top of the toolbar. Once the line appears on the screen, you can adjust the
line’s properties by placing the pointer of the mouse on the line, and then right-
clicking. From the menu select Horizontal Line Properties. You can then select
the thickness of this line, the width, and the alignment. It is not considered good
form to use this feature many times in a page. A subtle line that is centered and



perhaps running only 50% of the width is much better looking than a full-width
line.

Links (Internal)

Internal links are also called relative links, and refer to links made to other
documents in the same folder. For example, a professor may wish to provide
links to course syllabi as well as a Vita. These documents must be created
separately. They can be saved as either HTML files, or as PDFs. PDFs allow you
to create camera-ready versions of word-processed documents that are really
images. Most computers have the Adobe Acrobat Reader for PDF files.
However, software must be purchased for converting files to this format. PDFs
are perfect if you want your users to be able to download exact replicas of
existing hard-copy documents.

To create the link, simply type the text that you wish to become a link. Then click
the Link button on the toolbar. From the menu you must type the page location.
Since these are in the same folder on your U drive, you need only type
filename.html or filename.PDF (depending on which type of document it is).

If you create additional HTML documents and link to them, it is important that you
also provide links on those pages back to the homepage. Poor navigation of your
site will confuse your users and cause them to evacuate. Thus, if you have five
documents on your site (a homepage, three syllabi, and a Vita), it is important to
at minimum provide links back to the homepage, and preferably links between all
the pages so that users can move around easily.

Note: file and image names are case-sensitive on most web servers! They must
be specified exactly the way they were created.

Links (External)

Creating links to external sites is nearly as easy as it is to link to internal
documents. The only difference is that the full URL (Uniform Resource Locator)
must be typed.

One option to consider when linking to external sites is to have the link open in a
new window. This helps you retain visitors at your site. This is done by specifying
“new” in the Target window of the Link menu.

A second type of external link is the e-mail link. It is made the same way as all
the other links: highlighting the desired text, and clicking the Link button. Instead
of typing a URL, though, simply type the following:
mailto:yourname@server.com. This will create an active link that, when clicked,
will spawn an email form addressed and ready to send to you.




Images

It is easy to add images to your page. From the top of the toolbar, select Insert.
In the resulting menu, you can specify the name of the image you wish to add. It
is important to add this image to the homepage folder on your U drive. If you
have created a special Images subdirectory, then you need to specify this at
this time. An alternative is to use the Choose File button to help locate and
select your image.

There are numerous options for your images. You can leave their size to be
whatever the original wise, but you can also resize using the height and width
options. However, when resizing, it is important to keep your new size
proportional to the original. Also, never try to increase the size of an original,
because pixelation will occur.

Next, you can add a buffer around your image by adding space on either the
horizontal or vertical planes. This space is measured in pixels. which are little
“dot” of light. Buffers of 5-10 pixels create a nice amount of “white space” around
your images.

A border around the photo can also be specified at this time. For dark photos, no
border is necessary. Lighter photos should have a 2-pixel border added.

Finally, it is important to specify image alignment and how you would like text to
wrap around the image. The default shows text starting at the bottom of the
image, but other options exist. | prefer to use the two right options, so that my
text can literally wrap around the image, much like in a magazine article.

To have an image centered on the page, a slightly different approach must be
used. Add the image, and then highlight the image and/or accompanying text.
Click the Format tab along the top of the toolbar, and select Align. You can then
opt for right or center (left is the default).

Page Characteristics

It is important to establish some characteristics of the page. This is done by
clicking on the Format tab along the top of the toolbar. From the resulting menu,

first enter aTitle for your page. This is what users will see in the horizontal blue

bar across the very top of their screen when they are visiting your page. Next,
insert your name as the author, and provide a brief description of the page.

Finally, if you wish for your page to be indexed by search engines in a favorable
way, insert some Key Words that best describe you or your teaching and

research interests.



You can then select the Colors and Background tab to make a lot of other
subtle and notso-subtle changes to your page. You can select to let the user’s
chosen colors prevail, or you can override them by selecting your own. | always
choose this option.

You can then select your text color, as well as the colors for link text, active
links, and “followed” links. The default colors automatically appear in this pop-
menu, but you can click on any of the color samples and spawn a color grid from
which you can make your selection.

Also included in this array of choices is abackground color. The most common
choice is to use white, although virtually any color can be used. However, unless
you are doing a particularly artsy site, it is often considered amateurish to use
anything other than white.

Finally, you can add a background image, which you can specify by name at
the bottom of the pop-up. Background images are tiled across and down the
page, so use this choice wisely. Generally speaking, | use background images
sparingly, because they often look

Creating Your Own Files

Instead of editing documents that already exist, it is possible to use Composer to
create new ones from scratch. | have found it is easiest to first enter most of the
text first, and then go back for text and font effects, etc. Lists should be entered
only by using the appropriate List button, because it is not worth trying to convert
existing text to a list format.

When saving new documents, be sure to click File-> Save, and then save to the
homepage folder in the U drive. If you do not have a homepage, the file should
be called index. If you are creating other documents, they can be called any file
name you wish. The “.html” suffix will be added automatically.

Summary

Editing or creating web pages using Netscape Composer is fairly simple. The
more experience you have with it, these easier it will become. However, there are
limitations to Composer. It is not designed for professional web site developers. It
is an easy-to-use tool for those wishing to have a web presence, but without
becoming a programming ace. The preceding notes will give the novice sufficient
knowledge for keeping their site current.



